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Fast Start With Adobe Premiere Pro 
April 15, 2005   • 4:00PM  - 7:00PM 
Video input, three-point editing, timeline editing, video output, and more for beginning Premiere Pro 
users. If you’re new to Premiere Pro, don’t miss this important class. 
 
Introduction 
 
Optimal computer configuration: 
 
Processes: 
 
Make sure there are no unnecessary processes running in the background 
Go to Run>msconfig – shut down all processes not needed for editing 
 
Hard drive configuration 
I recommend at least 3 different drives: 
-Drive 1 (your C: drive) – only your OS and your programs should go here 
-Drive 2 (your data drive) – Have your Project file, any other files that you need to complete your 
project (titles, stills, music, etc). 
Also save in here your conformed audio files, as well and video and audio preview files. 
-Drive 3 (your video drive) – Save your captured video in here 
DEFRAGMENT- DEFRAGMENT- DEFRAGMENT 
 
Lesson 1  
Project Settings and Presets 
Use the ones created by Adobe, or the ones installed by your capture card’s software.  If you need to 
modify, go through the presets, and then save your settings.  Give it a name you’ll easily remember.  
Keep in mind to use presets that match your original footage, and not your output.  For example, 
something shot in DV, but to be delivered in DVD, should use DV presets. 
 
Initial Workspace 
By default, the editing workspace.  Position windows however you wish and save the workspace 
Windows>workspace>Save 
 
Preferences Settings 
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Edit>Preferences Go through these, and change according to your needs.  Things to look at are 
scratch disks, length of imported stills and Capture Device 
 
Keyboard Shortcuts Creating Your Own 
Edit>Keyboard Customization 
Assign different keyboard shortcuts to the functions you will use the most.  Remember, however, that 
Adobe tries to keep shortcuts between their different applications the same, so be careful when 
changing shortcuts. 
 
 
Lesson 2 
 
Capturing Video 
 Use the shortcut F5, or go under File>Capture 
 
Whole Tape 
Use the tape transport controls (look like a VCR’s controls), go to where you would like to start 
capturing (or the beginning of the tape), and click on the “Tape” button 
 
Batch Capturing 
 Play your tape, and as it plays select in and out points by either clicking on the “select In” or 
pressing the shortcuts “i” for in,  “o” for out.  Select an appropriate bin in your Project Window to 
send these batch capture files to 
 
Scene Detection 
 Click on the “scene detection” icon to make Premiere separate clips according to where you 
pushed the “pause” button in the camcorder.  Premiere accomplishes this by looking at the time stamp 
information in the tape. 
 
DV Device Control 
Select from a list of devices 
 
Saving Video Files 
Re-check that you will be capturing files to the appropriate HD, and that your system recognized your 
capture device.  Re-check that it will be captured in the format you desire, with the desired Codec 
(compressor / decompressor) 
 
File Management 
Make sure you name your clips something that you will recognize in the future.  If by any reason you 
need to re-create this project you should be able to do so by only re-capturing the raw footage. 
 
Lesson 3  
 
Importing Video Files 
CONTROL I to import files 
Double-click on an empty space in the Project Window 



File>Import 
 
Importing Audio Files (Ripping Audio From a CD) 
Import audio files the same way you import any other file,to rip audio from a CD you can use 
Windows Media Player.  Make sure you save to an appropriate folder 
 
Conforming Audio 
Premiere needs to conform any imported audio, even if it is part of a video file. Conforming audio 
means converting this audio to the current audio sample rate (the one you specified for the project), 
saving it at 32-bit quality. 
 
Project Window 
Any file that you will be using in your project, must exist in the Project Window. 
 
Creating Bins 
Create bins (folders) to keep your files and Sequences in order.  If all your files are together, this may 
lead to confusion later down the road 
 
Display Settings 
List or Icon view.  Use the different display settings available depending on how you are positioning 
your clips on the Timeline.  Use the icon view if you will be using the Storyboard approach 
 
Labels 
Use labels to quickly identify different file types 
 
Adding Notes 
Add notes to help you with your editing 
 
Lesson 4 
Adding Video / Audio to the Timeline 
Just the fact that a file lives in the Project Window doesn’t mean that it will live in your final video.  
The file must exist on the Timeline to be a part of your program. 
 
From Source Monitor 
Double-click the clip in the project window, and it will open in the Preview monitor window.  You 
can select in and out points (“i” for in and “o” for out) and from here place these clip sections on the 
Timeline 
 
From Project Window 
Drag from the Project Window onto the Timeline 
 
Storyboard / Automate to Timeline 
Automate to sequence to place several clips on the timeline at the same time.  You can even specify 
to add these clips to unnumbered markers (at the beat of music, for example), and to add the default 
video transition in between the clips.  This is best used when editing Storyboard Style. 



 
Adding Sound 
Add sound to your work the same way as you added video.  Keep in mind that a stereo clip cannot 
live on a mono track, and vice versa. 
 
Lesson 5 
 
Adding Transitions 
Under the effects window, select the transition you would like to use.  Drag it in between the clips 
that require such transition. 
You can also add the transition using the shortcut CONTROL D for video - SHIFT CONTROL D for 
audio.  The CTI must be placed at the transition point.  To move from edit point to edit point use the 
page up and page down keys. 
 
Default Transition (Video & Audio) 
You can make any transition the default transition by right clicking on the transition’s name and 
select “set selected as default” 
 
Customizing Length of Default Transition 
Under your preferences files – general.  Change the length of your default video transition and audio 
transition 
 
Slip and Slide Edit Tools 
A slip edit shifts a clip's In and Out points forward or backward by the same number of frames in a 
single action. By dragging with the slip tool, you can change a clip's starting and ending frames 
without changing its duration or affecting adjacent clips. 
 
A slide edit shifts a clip in time while trimming adjacent clips to compensate for the move. As you 
drag a clip left or right with the slide tool, the Out point of the preceding clip and the In point of the 
following clip are trimmed by the number of frames you move the clip. The clip's In and Out points 
(and hence, its duration) remain unchanged. 
 
Ripple and Roll Edit Tools 
A ripple edit shortens or lengthens a clip, and the program will get shorter or longer according to 
how many frames you added or removed from the clip. This operation is only possible provided there 
are enough frames available to perform the operation. 
 
A rolling edit trims an adjacent Out point and In point simultaneously and by the same number of 
frames.  This will not affect the length of the program. 
 
 
Speed / Rate Stretch 
To change the speed of a clip you can select Clip>Speed, or use the rate stretch tool 
 
  
Lesson 6 



 
Clip Markers 
Place clip markers by double clicking on the clip, once it open in the Preview monitor Window, you 
can add the marker, and it will appear in the clip.  You can also right-click and select Add clip 
marker.  You can add numbered and unnumbered markers to your clips 
 
Sequence Markers 
Place clip markers at any place in the Sequence.  Use the shortcut (* on the numeric keypad). 
You can also right-click and select Add Sequence marker.  You can add numbered and unnumbered 
markers to your Sequences 
 
Chapters for DVD Creation 
You can have your Sequence markers serve as chapter markers for DVD creating.  Either by selecting 
this option when creating this DVD from within Premiere Pro, or by double-clicking on the marker 
and selecting (and even naming) your marker so that programs like Encore DVD will recognize these 
markers as DVD chapters 
 
 
3 Point Edit 
All edits in Premiere have 4 points.  The in and out point of the source clip, and the in and out point 
in the Sequence (where the clip will be placed).  Select in and out points either on the Sequence or on 
the Source Clip, and after that you only need to select one other point either on the Sequence or on 
the Source Clip.  The 4th point will be created automatically. 
 
Lesson 7  
 
Effects Control Window 
We use the Effect Controls Window to work with any clip-based effect.  You can add Keyframes, and 
control the settings of the different effects.  You will be able to see a mini-timeline, representing the 
clip. 
 
Motion / Opacity 
Control Motion and opacity from within the ECW, no need to apply any additional effects (these 2 
are already applied).   
You can also control motion from within the Program Monitor window. Create Motion by adding 
Keyframes. Control and adjust Bezier curves in your motion path 
 
Keyframes 
A keyframe marks the point in time in a clip where you specify a value for an effect or property. You 
can specify different values for different points in your clip, and Premiere Pro will interpolate those 
values, creating a progressive change in time. 
 
 
Filters 
 
Color Corrector 



Adjust Black, White and gray levels to optimize your color 
Compare the corrected clip with the original one by double-clicking the clip in the Timeline, now it 
will appear in the review Monitor Window. 
 
Set the Black Point – Darkest part of your image  
Set the White Point  - Whitest part of the image 
Set the Gray Point – Neutral part of the image – experiment with this and move the eyedropper tool 
until you find a color that optimizes your overall clip 
 
You can also adjust HSL and RGB levels in your clips, and enable the Video Limiter, to remain 
“legal” 
 
Color Match 
Match the colors of one clip to the colors of another clip.  
Place the 2 clips side by side by placing the CTI on one so you can see it in the Program monitor 
window, and double clicking o the other one so that it opens in the Premiere Monitor Window.  You 
can even gang the 2 monitors. 
Use the eyedroppers to match the selected colors 
 
Lesson 9  
 
Titler 
You can use the Adobe Titler Designer to create titles that you can add to your work 
 
Templates 
The Titler comes with a variety or templates that you can use and customize – click on the template 
button and choose an appropriate one 
 
Saving Template 
Create your desired template and click on the template button.  From the Wing menu select “Save as 
Template”.   You can also go under Title > Templates. Choose Import File As Template from the 
Templates options menu.  
 
Styles 
You can apply some of the styles that Premiere Pro already has, select the text or object and then 
click on the desired style to apply. 
 
To create and save a style select and object or text and from the styles menu, choose New Style – 
name it appropriately and click OK. 
 
 
To select a Style as the Default one, select your desired style and from the menu choose Set Style As 
Default  
 
You can also load or save style libraries by selecting the appropriate menu item. 
 



Creating a Credit Roll / Crawl 
Choose Roll or Crawl from the Title Type menu, then start creating your title in the drawing area. 
Choose Title > Roll/Crawl Options. 
Specify the appropriate Timing options, and then click OK. 
 
Start Off Screen, End Off Screen so that the title starts and ends off screen 
 
Pre-Roll - Specifies the number of frames that play before the scroll begins. 
 
Ease-In - Specifies the number of frames that the title scrolls at a slowly increasing speed until the 
title reaches the playback speed. 
 
Ease-Out - Specifies the number of frames that the title scrolls at a slowly decreasing speed until the 
scroll completes. 
 
Post-Roll - Specifies the number of frames that play after the scroll completes. 
 
Left to Right, Right to Left - Specifies the direction in which the crawl moves. 
 
The longer the clip in the Sequence, the slower the Roll or Crawl will be 
 
Lesson 10 
 
Alpha channel 
An alpha channel is an extra channel in addition to the visible color channels (such as RGB), that 
defines transparent and semi-transparent areas.  
Premiere will recognize a file that contains an Alpha Channel, and when you place this clip on one of 
the tracks (2 and up), the alpha transparency will automatically be applied.  You can also choose to 
ignore the alpha transparency information on your clip. 
 
Matte 
A file or channel that defines or modifies the transparent areas of its clip or another clip.  
 
Keying 
Defining transparency by a particular color (color key) or brightness value (luminance key) in an 
image. Pixels matching the key color become transparent. Use keying to remove a background with a 
uniform color, such as a blue screen. 
 
Chroma Keying 
Select a color or a range of colors in the clip to be transparent.  
Select a key color by clicking the Color swatch or by dragging the eyedropper to a color in the 
Monitor window. Adjust Similarity, Blend, Threshold, Cutoff, and Smoothing to improve the quality 
of your keying. 
You can also select the Mask Only to display only the clip's alpha channel. 
 
Track Matte 



Use the Track Matte key to show one clip through another, using a third file as a matte that creates 
transparent areas in the superimposed clip. A matte containing motion is called a traveling matte or 
moving matte. The matte may consist of motion footage, or you can animate a still image matte in 
another Sequence and nesting this moving still Sequence. 
 
You can create a still in the Titler and animate it on a Sequence, nest this Sequence into the current 
sequence and place this on video track 3.  Place your other 2 clips on video tracks 1 and 2. 
 
Apply the track matte effect to the middle clip and select video track 2 as your matte (select alpha or 
luma from the effects properties. 
 
Make the traveling matte clip invisible. 
 
  
Lesson 11 
 
Exporting Your Video 
To tape 
You can export your video by playing the Timeline, and while its playing, record with your DV 
device.  You can also choose file>export to tape, and this way you can have control over your DV 
device.   
 
DVD 
You could create a DVD from within Premiere Pro, provided you have a compatible DVD burner in 
your system.  A DVD created in Premiere Pro will play from the beginning, but have no menu.  You 
can indicate if you would like for the DVD to recognize Sequence markers as chapter stops. You need 
to have enough space in your hard drive to make this operation possible 
 
To export a sequence to DVD, open the Sequence and go under File > Export > Export To DVD. 
Choose your desired encoding settings, select the DVD burner and finally, double-check your settings 
before creating the DVD. 
 
For CD 
Video CD will allow you to play the video on a computer.  You’ll need to export your video as a 
Window Media file, QuickTime, or mpeg.  With additional software you can have this CD auto run 
when your viewer places the CD into the CDROM drive of their system. 
 
Web 
Select File > Export > Adobe Media Encoder,  
Choose from the many presets that Premiere Pro includes.  Keep in mind the following: 
Streaming video - video is sent to you frame by frame, without downloading a large file to your hard 
drive.  You’ll need higher connection speeds to play flawlessly. 
Progressive downloadable video 
A progressive download movie – begins playing as soon as it has enough material to start playing, 
even if the whole file hasn’t been downloaded yet.  



MPEG video – there are different kinds of mpeg videos.   The kind usually used for use for CD-
ROM is MPEG-1, MPEG-2 is used for DVD video, MPEG-3 is an audio-only format and MPEG-4 is 
used for delivering high-quality audio and video streams from cell phone to broadband and beyond. 
Animated GIF is usually used for animating a company logo over the internet.  It is viewable over 
most web browsers. 
 
For optimal results in exporting video for the web, consult your web master. 
 
Lesson 12  
 
Multiple Sequences -  
You can insert, or nest, sequences into other sequences. A nested sequence appears as a single, clip.  
Instead of applying effects to clips one by one, you can apply to the whole Sequence. You can repeat 
(reuse) these nested sequences and use complex compositing techniques 
 
When nesting sequences, keep in mind the following: 
You can't nest a sequence within itself. 
Any changes to the parent Sequence will be reflected in the nested one 
Nested Sequences may require additional rendering time 
 
To nest a sequence in another sequence rag it from the Project Window to the desired track. 
 
To open the source of a nested sequence, Double-click a nested sequence clip.  
 
Lesson 13 
Premiere Pro and Multi-camera Editing 
 
One of the questions that I hear more often is; How do I edit multi-camera events using Premier Pro – 
it takes me forever! 
 
Get your video into the computer 
Capture your video into the computer.  This should not be done through batch capturing, but capture 
the whole tape instead (good and bad footage).  The reason behind this is that you will need to sync 
your footage only once.  Also, please make sure that the stop button is never hit during the actual 
recording of the event; this will make life much, much easier! 
 
Try not to stop the camera during the recording process 
Let’s assume that you will be editing a 3-camera seminar.  For your raw footage you should have 3 
clips that are as long or longer than the seminar itself was.  Of course, sometimes, when you are 
recording longer events, it is impossible to fit everything onto one MiniDV tape, so it becomes 
necessary to change tapes in the middle.  Make sure that all your cameras don’t do it at the same time, 
and that the important audio that is happening at the moment will be covered by another recording 
device.  Also, if there are parts that you know you will be cutting out (like change of speaker, or 
change of slides, etc), try to make your tape changes in here  
 
Add all the audio you have 



So now you have 3 clips, which are in Premiere’s Timeline, one on top of the other.  If you have any 
audio tracks that have important audio in both channels, you might want to separate these into mono 
tracks.  To do that, select the file on the Project Window and then go under Clip > Audio Options > 
Breakout to Mono clips, and Premier Pro will create 2 separate tracks, both mono that will contain the 
audio channels that you need to complete the project.  Place these newly created audio tracks right 
under the original video track so that it remains in sync with the video file that it came from. 
 
Sync these clips 
Now we need to sync these files, which we’ll do by using markers.  Double-click on the first video 
file, and it will open in the Source Monitor Window, go to a point in the seminar that you will easily 
be able to find in all 3 video files. Once you get there, place an unnumbered marker in here  - you 
place an unnumbered marker by clicking on the marker icon right under the Source Monitor Window.  
Double click on the second clip and scroll until you get to the exact same place, and place an 
unnumbered marker here as well – do the same thing with the third clip.  Now, all of your clips 
should have a marker in roughly the same place.  Move the clips so that the markers are one right on 
top of the other (in the same time spot). 
 
Now we need to fine-tune this so that the clips are really in sync (what we did before was to get the 
close enough).  You can expand the audio tracks and move the clips left or right until the audio 
waveforms are one on top of another, perfectly in sync.  You’ll be able to easily sync through the 
waveforms even if your audio came from different sources and you have different levels. To move 
your clip left or right by one frame press the Keyboard shortcut “ALT + .” or “ALT + ,”. 
 
The whole syncing process shouldn’t take longer than 30-40 seconds, even when working with 3 
cameras.  If you need to sync a tape-change, then it will take a little bit longer, but not too much 
longer.  
 
To sync audio from a minidisk recorder or other source, use the same technique already discussed.  
To sync audio that originated from one of the AVIs that you are currently using in the Timeline, all 
you need to do is to place this audio right under the source AVI, and make sure that it is in the 
EXACT time position as its parent clip.  Easy! 
 
Up to this point you should have:  all your clips on the timeline, all the audio clips on the timeline; all 
the clips (including all the audio) should be in sync. 
 
Make the clips small 
Select the top clip on the Timeline (you select it by clicking it) and now click on the main screen in 
the Program Monitor Window.  This will give you access to the Motion Controls for this clip – you’ll 
see the control points.  All you need to do is click on one of the corners and adjust the size as you 
wish.  Make this clip a lot smaller and position it on the top left side of the screen. 
 
Select the second clips and do the same thing, except this time you should position the clip on the top 
right hand side if the screen.  Do the same thing with the third clip and position on the bottom part of 
the screen.  Position all of these clips so that they do not overlap and you can see all of them at the 
same time. 



 
Play the Timeline 
Press the space bar to play the Timeline, and as it plays, you’ll be able to see all 3 cameras.  When 
you want to go from one camera to the next, you should place an unnumbered marker in that position.  
Placing an unnumbered marker is really easy - press the * key located above the numeric pad (not the 
one above the 8).  Go through the whole seminar this way, playing it real time, and pressing the * key 
every time you want to go from one tape to the other.  Don’t worry if you make a mistake, you can 
easily us the “undo” function (CONTROL +z) or you can adjust the edit later on with the different 
edit tools.  You are not really deleting anything at this point; all you are doing is adding markers. 
 
Lock the Audio Tracks 
Before we cut any video, we need to lock the audio tracks (all of them).  Click on the little square that 
is next to the loudspeaker icon and a little padlock should show.  This means that the track is locked.  
To further remind us that the track is locked, there will be little thin diagonal lines running all across 
the track.  Lock all of the audio tracks. 
 
Create shortcuts 
Now we need to create some shortcuts.  Go to Edit >Keyboard Customization and expand the 
“Marker” command (click on the little triangle to the left of the name).  Expand “Go to Sequence 
Marker” and select “Next”.  Assign any keyboard shortcut you wish for this function – I use F12.  
Select something that you’ll remember. Collapse the “Marker” item and expand the “Sequence” item.  
Select the item called “Razor at Current Time Indicator” and select a shortcut for this as well.  I use 
the / that shares the same key with the “?” – don’t use the slash above the ENTER key! 
Save your shortcuts and give them the name “Multi-camera Editing” 
 
Chop-Chop 
It is time to cut!  Fortunately this is fun (at least for me!).  Click on the Timeline and go to the 
beginning of the video.  Press (alternating) the “F12” key and then the “/” key over and over until all 
on the markers have a cut right on them.  You’ll be done with the stage in no time at all, in fact, even 
the longest ceremony shouldn’t take you any more than 1 minute. 
Delete clips 
Go through the seminar and delete portions of the clips that you know you won’t use, so that only one 
clip per section is left.  Drag these clips to track 1 in the Timeline (if you wish). 
 
Resize the Clips 
You have all of these clips, but they are all small, throughout the whole seminar.  Select one of them, 
and then go to the Effect Controls Window, and click on the reset button, you’ll see that now this clip 
is the size and in the position that it should be.  Click on the name Motion Controls for this particular 
clip, and copy (CONTROL +c).  Click on the Timeline and select all of the clips (CONTROL +a), 
and then paste the Motion Controls Setting (CONTROL +v).  Now you’ll see that all of the clips are 
back to the size they should be. 
 
What about the audio? 
Let’s unlock the audio, and for this click on the same icon that you clicked to lock it.  Now you’ll 
notice that the diagonal lines disappeared.  All ceremonies that I have videotaped have distinct 
sections to them, welcome remarks, readings, music vows, etc.  Usually the audio source that we use 



for each one of these sections is different.  All you need to do is cut the audio clips at the point where 
you need to switch from one audio source to another, and delete the audio clips that you do not need.  
This should be really easy if you named your clips or tracks appropriately.  You can drag all the audio 
clips onto one track, if you wish, but remember that in Premiere Pro you cannot have mono and 
stereo clips “living” in the same track.  So, if you have both mono and stereo clips you will have to 
have at least 2 audio tracks. 
 
Transitions 
If you would like to add transitions between your clips, now is the time to do so.  You can add video 
and audio transitions really quickly by using the Shortcuts to add the Default Transitions (both audio 
and Video).  Place the CTI (Current Time Indicator) at the beginning of the Timeline and press the 
shortcut “PAGE DOWN” on your keyboard.  This will take you to the next edit point.  To add the 
default video transition press “CONTROL + d”, and to add the default audio transition press” 
CONTROL + SHIFT + d”.  You can go pretty quickly through the whole ceremony adding 
transitions. 
 

Luisa Winters has been in the professional videography industry for 15 years.  Her Premiere Pro 
Training DVDs can be found on her website www.videotrainers.com
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Luisa Winters has been in the professional videography industry for 15 years. A multiple award 
winning videographer / editor, Luisa believes videographers should attend her workshops because 
they will add editing techniques to their repertoire that they likely have never thought of before. She 
will give tips to make editing much more productive, faster, and far more inventive. 

An accomplished videographer, editor, 3D animator and graphics designer, her 3D animations of 
the Naval Academy logo have been seen on PBS as well as in private video productions. She has 
created and edited scores of video projects for dozens of corporate, government, and educational, 
commercial and private clients.  Since 1999, Luisa has conducted training sessions and master classes 
for Adobe Premiere Pro, which have helped thousands of videographers learn and master Adobe 
Premiere and other Adobe software programs. 

Luisa has been a featured instructor at training workshops all over the US, Central and South 
America- She has given workshops in the following cities: 

• Baltimore, MD 
• Annapolis, MD 
• Washington, DC 
• Philadelphia, PA 
• Boston, MA 
• San Francisco, CA 
• Sacramento, CA 
• San Diego, CA 
• Dulles, VA 

• Fairfax, VA 
• Orlando, FL 
• Chicago, IL 
• New York, NY 
• Las Vegas, NV 
• Los Angeles, CA 
• San Juan, Puerto Rico 
• Santo Domingo, Dominican Republic 
• Buenos Aires, Argentina 

 

Luisa is a Johns Hopkins University Graduate and is fluent in both English and Spanish. 

 
Luisa’s contact information: 
 
www.videotrainers.com
luisa@videotrainers.com
(410) 672-5200 
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